Yoast is generating http in Canonicals without “s”. Is this a problem?

Share This Post

ForumCategory: WordPress Discussion & TroubleshootYoast is generating http in Canonicals without “s”. Is this a problem?
Mohammad Athar Staff asked 11 months ago

Should I include “s” in http on every page by myself?

Yoast is generating http in Canonicals without “s”

2 Answers
Best Answer
Fajal Shah answered 11 months ago
Yoast has been known to have this problem for a long time. Rank math. Switch to rank math. But there are others too, and I'm not sure why Yoast just won't fix this. As I said this is been going on for a long time. I will say this though I did use it for years and I never experienced any of these problems. But I saw this posted enough times to go ahead and make that switch to rank math. I think it's better overall and the UI is definitely nicer. Here is the solution
Poonam answered 11 months ago
Hey there, this is a pretty easy fix! Just head into your settings and make sure under General you have an HTTPS included in the website URL. This should fix it. If it doesn’t it may be because your MYSQL database file isn’t updating, which can be found under the wp_options table in PHPMYADMIN, where you can overwrite it!

Subscribe To Our Newsletter

Get updates and learn from the best

More To Explore

8 Best Free Soovle Alternatives
Keyword Research

Soovle – 8 Best Free Alternative Tools

Created in 2008, Soovle is a search engine that aims to make search more efficient and user-friendly. It does this by providing keywords from a

7 Best Free Keyworddit Alternatives
Keyword Research

Keyworddit Tool – 8 Free Alternatives

In SEO, keywords are everything. And finding the right ones can be a real challenge, especially if you’re targeting a specific niche. But what if

Do You Want To Boost Your Business?

drop us a line and keep in touch